Это многостраничный печатный вид этого раздела. Нажмите что бы печатать.

Вернуться к обычному просмотру страницы.

Пакеты обработки данных

Пакет обработки данных предназначен для настройки автоматического запуска заданий по обновлению данных.

В состав пакета могут входить следующие шаги:

  • составы выгрузок данных;
  • сценарии обработки данных;
  • другие пакеты обработки данных.

Перейти к списку пакетов можно через начальную страницу или через меню «Главное» / «Настройки» / «Пакеты обработки данных».

В открывшемся окне появится список доступных пользователю пакетов. Пакеты могут быть сгруппированы в папки.

1 - Настройка пакетов обработки данных

Для настройки пакета обработки данных в документе необходимо заполнить «Наименование», «Группу» (может остаться пустой) и «Проект» (если используется).

Выбор режима выполнения

При настройке пакета пользователь может выбрать два режима выполнения: последовательно или параллельно. При выборе режима «Последовательно» все шаги пакета будут выполняться друг за другом. В случае выбора режима «Параллельно» настройка выполнения шагов будет выполняться в отдельной форме «Состав пакета».

Последовательное выполнение

Для добавления шага необходимо нажать кнопку «Добавить» и выбрать тип шага из списка:

  • «Составы выгрузок»;
  • «Сценарий»;
  • «Пакеты обработки данных» (шагом может являться другой пакет получения данных).

После выбрать в качестве шага элемент из соответствующего списка.

Шаг пакета можно исключить из выполнения. Для этого нужно снять флаг в колонке «Включить».

Параллельное выполнение

При параллельном выполнении пакета, шаги пакета выполняются по заданным правила очередности. Настройка состава пакета происходит в интерфейсе WorkFlow. Для настройки параллельного выполнения необходимо:

  • в пакете выбрать «Режим выполнения: Параллельно»;
  • перейти на вкладку «Состав пакета»;
  • откроется интерфейс WorkFlow, где необходимо произвести настройку шагов.

Порядок работы в интерфейсе WorkFlow состава пакета аналогичен порядку работы с интерфейсом WorkFlow в сценарии:

  • на поле «WorkFlow» переносится нужный тип шага сценария;
  • с помощью кнопки «Редактировать шаг» на шаблоне открывается форма выбора элемента сценария, в соответствии с выбранным типом;
  • шаги соединяются между собой связью портов;
  • запуск до конкретного шага осуществляется через кнопку «Выполнить до этого шага».

Настройка параметров

При необходимости можно заполнить параметры, которые будут действовать для всех шагов пакета. А если настроить параметры для нескольких запусков, то пакет будет выполняться столько раз, сколько пакетов параметров настроено.

Вывод схемы выполнения пакета

Визуальная схема — позволяет увидеть, как взаимодействуют разные шаги получения и обработки данных, не изучая исходные документы и тексты скриптов. Пример графического представления состава пакета представлен ниже.

Открыть схему можно из списка пакетов, нажав на кнопку. Схема строится на основе указания названия баз данных и таблиц в документах («Состав выгрузки», «Сценарий»).

2 - Включение пакета в расписание

Для настройки автоматического запуска пакета:

  • для активации расписания регламентного задания установить флаг «Активно» на форме редактирования пакета;
  • настроить расписание запуска регламентного задания по сбору данных, нажав на ссылку «Расписание не задано».

Просмотреть настроенное расписание можно через меню «Главное» / «Сервис» / «Планировщик запуска пакетов». В расписании по дням и часам визуально представлены запланированные к запуску пакеты. Длительность и цвет пакетов в расписании отображены исходя из настроек.

3 - Настройка рассылки оповещений о выполнении пакета

После выполнения пакета обработки данных, программа может прислать оповещение на электронную почту.

Чтобы программа могла отправлять оповещения, нужно настроить учетную запись электронной почты (см. статью «Настройка почты»).

Для настройки списка рассылки нужно перейти в «Главное» / «Настройки» / «Списки рассылок».

Далее нажать кнопку «Создать»:

Далее заполнить «Наименование» (см. рисунок ниже, 1), «Адрес электронной почты» (см. рисунок ниже, 2). Если необходимо рассылать оповещения на несколько адресов, можно добавить поля на кнопку «Добавить» (см. рисунок ниже, 3). Записать и закрыть форму:

После создания списка, его можно выбрать в «Пакете обработки данных» в подменю «Контроль работы», поле «Получатели рассылки».

4 - Лог выполнения пакетов обработки данных

Для отслеживания процесса получения и обработки данных можно воспользоваться журналом выполнения пакетов. Доступ к журналу через меню «Главная» / «Логи» / «Выполнение пакета»:

В журнале пакетов можно просмотреть записи о выполненных и выполняющихся пакетах. Цветом указано состояние пакета и был ли он выполнен успешно:

  • зеленый — завершен и выполнен успешно;
  • синий — в процессе работы;
  • красный — выполнен с ошибками.

Каждый лог о выполнении можно открыть и просмотреть подробные данные о каждом шаге.

Документ «Выполнение пакета» отображает следующую информацию о начале, окончании и длительности выполнения пакета, наименование пакета, а также информацию о состоянии выполнении пакета.

В табличной части выводится «Шаг пакета», признаки «Шаг начат» и «Шаг выполнен», ссылка на документ лога выполнения шага (при нажатии на ячейку будет открыт документ лога с подробностями шагов выполнения состава выгрузки, сценария постобработки или пакета), информация о работе шага, список ошибок во время работы пакета.